Game no longer in Google Play Store?

I'm just asking. I can't find it anywhere. I tried downloading it from desktop but it says my device is incompatible.

Is this supposed to be the new update?


  • NG_FilipeNG_Filipe Community Manager, Staff Posts: 611

    Game is not available for desktop. You will be able to play the game on Android or iOS devices.

    Have fun!
  • TheRealProffyTheRealProffy Member Posts: 6
    edited June 2020
    Hi, apologies. I think I misphrased my question.

    I found out in my Android that it's just incompatible, can't install it even if it's found in my library (can't be found in my Play Store search). Android version of my phone (J6) is version 9. Are there any issues with that specs?

    Also, I tried the things to do when error appears (mentioned in another post); I cleared the data and cache of my Play Store, but to no avail. I think all the other related apps are to their latest version.

    Thank you! I look forward to seeing the game again! :)
  • NG_FilipeNG_Filipe Community Manager, Staff Posts: 611
    First, please try clearing the Google Play Store cache. Apps > Google Play Store > Storage > Clear Cache. Then restart your device, and open the Google Play Store. Agree to the terms & conditions if asked.

    After this, try to install it. If this does not help, try clearing Google Play Store Data (button next to Clear Cache), and repeat the above procedure.

    Your device can be marked as incompatible if your device has been rooted or is running a boot loader. In this case you will need to reverse the root on your device, once this is done the Play Store will allow the game to be installed.

    If those steps don't help, get back to us providing a screenshot of the version of your Google Play and your Play Protect Certificate? You can access that information following these steps:

    1. Open your Google Play app
    2. Select Menu (the three horizontal line on the top left of your screen)
    3. Select Settings
    4. Search for Play Store Version (If you tap this option, it will update your app to the latest version)
    5. Right under it you shall have the Play Protect Certificate
    However, even if your device fills all the criteria, it still might not be able to run the game. In these cases, we may not be able to know the reasons behind it.

    I hope this information was useful and to hear good news from you soon.
  • TheRealProffyTheRealProffy Member Posts: 6
    Hello again.

    I feel that I won't be able to play for a while due to the issue. I was assured (and I'm pretty sure) that my phone was never rooted. I also checked the specs found on the CPW Helpshift site and I'm also sure that my device is capable of running it. I also tried the steps from the top, and again to no avail. The reasons may indeed be unknown.

    That's pretty much it. I bid you good luck for the future updates. Thank you very much for the responses. Much appreciated!

    [Attached here is the info you may be looking for. Play Store is in latest version.]
  • Major_CrisisMajor_Crisis Member Posts: 1
    I've encountered the same problem - I can find CPW songs but not the game itself - poor support after nearly 8 years playing the game. First event I've missed for at least 7 years if not more. I used to buy gems but stopped when I realised the developers had abandoned the game and its players by not delivering the promised updates. I'm missing the game and would return in a heartbeat - IF I could find the game in Play Store. I've had the above info sent TWICE by someone called Gary and done all it suggests but I've still lost my three accounts. RIP Holly Wood, Private Parts and Major Crisis. Hope to be able to resurrect them some time in the future when Next sort out the problems. Thanks to all. 
  • NG_FilipeNG_Filipe Community Manager, Staff Posts: 611
    Hi guys, thank you! Our team is investigating these reports.
  • OblioOblio Member Posts: 219
    edited June 2020
    10 out of 30 members of my Posse “40 something” have yet to post any points this event. I expect most of these players have been unable to Update to 4.0.
    Either because their iOS hardware is too old, or their Android devices are “incompatible”. 

    My Android Tablet is “incompatible” with the update... I am the original owner and have only used it to play Compass Point: West, it has never been hacked or rooted, or any other modifications. I have followed all of the recommendations listed above, Updated System Software, cleared caches, cleared data etc. all to no effect. 

    Fortunately my iPad mini 4 is compatible, so my primary account is active, but not my other account.

    The Hardware/Software Requirements on the Next Games Website appear to be out of date (It mentions iPhone 6 as current Apple Hardware)

    I miss the companions I have rode with every week for the last 6 years.

    Any additional information or suggestions would be appreciated.

  • NG_FilipeNG_Filipe Community Manager, Staff Posts: 611
    edited June 2020
    Hi guys!

    To help us investigate this issue we would need the following information from you:
    • Device Model:
    • Android version:

    How to find Device Model:
    The easiest way to check your phone’s model name and number is to use the phone itself. Go to the Settings or Options menu, scroll to the bottom of the list, and check ‘About phone’, ‘About device’ or similar. The device name and model number should be listed.

    How to find out Android version:
    1. Open your phone's Settings app.
    2. Near the bottom, tap System And then Advanced And then System update.
    3. See your "Android version" and "Security patch level."
  • OblioOblio Member Posts: 219
    Device: Galaxy Tab A (2016) 
    Model: SM-T280
    OS: Android OS 5.1.1
    Android Security Patch Level: 2017-12-01

    These are the most recent compatible with my tablet
  • OblioOblio Member Posts: 219
    The only way I can find Compass Point: West on the Google Play store is to use the link on Next Games Website.
  • TheRealProffyTheRealProffy Member Posts: 6
    Device: Galaxy J6
    Model: SM-J610G/DS
    Android Version: 9
    Security Patch Level: Apr. 1, 2020

    Recently updated my softwork, didn't work still.
  • NG_FilipeNG_Filipe Community Manager, Staff Posts: 611
    Good morning everyone!

    A new version for Android is now available. To get it, go to the Play Store -> Search for Compass Point: West -> Update game

    Please note that this update won't show under your Apps and Games Library.

    Stay safe!
  • OblioOblio Member Posts: 219
    There are no notes about what the update addresses, I can’t check myself as my Samsung Galaxy Tab A is still incompatible.
  • TheRealProffyTheRealProffy Member Posts: 6
    NG_Filipe said:
    Good morning everyone!

    A new version for Android is now available. To get it, go to the Play Store -> Search for Compass Point: West -> Update game

    Please note that this update won't show under your Apps and Games Library.

    Stay safe!

    In my case, it's now compatible, so thank you.

    Also, I'll plug in the bug that someone is talking about in another discussion, about the cards being in "a single file" that you can't select it in an order you want.
Sign In or Register to comment.