Please help me

soulpussoulpus Member Posts: 3
My game is stuck on main loading screen, have uninstalled and reinstalled, dont know what else to do. It has been like this for 12 hours. soulpus level 63 Legionnaire guild. Please help


  • zbotzbot Legendary Moderator Posts: 6,474
    @soulpus press 3 fingers on the screen for 10 seconds while the game is loading to access the help screen. If you can't access it, it's most likely a connection issue. Sometimes doing this will allow the game to load. If you can access the help menu send a in game support request so support can check out what's going on.
  • soulpussoulpus Member Posts: 3
    Hi there, ty for quick reply, i tried your suggestion and i was able to access the help menu, so im assuming its not a connection issue.i asked for help but i cant get any support over the weekend. When i uninstalled and reinstalled the game loads fine but when i try to load soulpus level 63 it wont load. Thanks for your help.
  • zbotzbot Legendary Moderator Posts: 6,474
    @soulpus looks like an issue with your save game, you will need to wait for support to respond.

    Check the contact us menu to see if you can still see your original support request. If you don't see it you will need to contact support again. Sometimes this happens when you uninstall and reinstall the game.

    Also do you know you were doing before the game froze?
  • mommabearmommabear Member Posts: 3
    I have tried the last trial for this week twice, both times it won't let me set the explosives. I have to flee. What's the problem?
Sign In or Register to comment.