New google account now no ads on new restart

Eited79Eited79 Member Posts: 1
Hello i restarted the game just under a week ago and since doing so the cinema is completely broken and I cannot get option to do ads for creates, and also after each mission I am not able to view ads to open any additional 3 creates. Very frustrating. My device is up to date on android v7. I linked the game to my phone and still have the issue.

So far I have tried
Reinstalling the game entirely
Deleting the data for the google account and restarted the game.
Playing it on another device
Changing the advertising is and settings in the google account

I have played the game for some time and never had any issue like this before, I feel like I have tried everything I can, has anyone else had this and is possibly able to help please


  • David_H79David_H79 Member Posts: 1,866
    Do you mean restarted from mission1?
    If so, ads are not available from day 1.
    They start after playing a few days. Not sure how many at the moment.
    Maybe @Kaz has the answer.
  • KazKaz Member Posts: 1,423
    @David_H79 is correct. You'll start getting ads after one week (7 days). If your new account is more than 7 days old and still you are not getting any ads, let me know! And tell me in private your in-game name and name of your guild! :)
  • RiccardoTWDRiccardoTWD Member Posts: 1
    @Kaz Hi, I've had the same issue and my account is 10 days old
Sign In or Register to comment.