Post snow update issue

ChuckCtChuckCt Member Posts: 2
Made a $9.99 purchase of 50 radios, gold and supplies.. never received. 2 hours later tried again and pop up stated already purchased and would be restored, next pop up stated returning to store..no good iPad locked up and had to be shut down. Upon restart still no purchase and a lot of the help screens just boot me out of the game....Help

Best Answer

Answers

  • JenngJenng Member Posts: 2,733
    Uh oh. @ChuckCt pretty sure the instructional class in the corner of camp specifically states to proceed with caution on purchasing during update day.......... in case of weirdness. You’re gonna have to submit a ticket ( and possibly an essay) now.


    TJSCarl_s_Hatimacharlie
  • ChuckCtChuckCt Member Posts: 2
    Well c**p last time I tried that game booted me out, but did leave a help request on the website..time will tell
  • KazKaz Community Manager Posts: 1,423
    @ChuckCt

    Hey Chuck!

    Sorry to hear about that.

    Do you mind reinstalling your game and then trying to contact our support again? It seems your game is saved on your Google/Game Center account, so to recover it, just tap settings > restore (or connect) game. Let me know how it goes afterwards!

    Thanks!
Sign In or Register to comment.