Can't install game Android 10 - RESOLVED

Edwin_WWEdwin_WW Member Posts: 37
edited February 25 in Game Issues
Does anyone have suggestions on why I can't install the game on my Note9? It's android 10, I have tried uninstalling and installing many times, after deleting cache and data from Google Play and other suggested apps, as well as, rebooting the phone and changing wi-fi. I also reset all settings, but that didn't help. My last option is a full Factory reset, but I was hoping for other suggestions.


  • bladgierbladgier Member Posts: 2,108
    Known issiue, I'm afraid you can't do anything but wait for the fix and play on another device.
  • Edwin_WWEdwin_WW Member Posts: 37
    Thank you @bladgier , but since it's my only device, I'm going to do factory reset, after I backup all my stuff.
  • Edwin_WWEdwin_WW Member Posts: 37
    Success! I cleared all data, not just cache, from ALL Google apps and rebooted again, then I was able to install No Man's Land.
  • txcowboytxcowboy Member Posts: 30
    @Edwin_WW I know this is a bit of a stretch, but I am stuck.

    The story goes my phone shit the bed and so Verizon sent me a replacement device. It came preloaded with android 10. I have tried multiple different things to get the game to work.

    I did save my game sometime before my phone died. The issue is the new phone wont even open the app. It sounds like you got it to work. I was wondering if you could explain it to me better what you did?

Sign In or Register to comment.