Today's season 10 mission

2»

Comments

  • ReeconnReeconn Member Posts: 512
    This happened to me ,switched to 2 Warriors and it worked fine
    Wild Walking Family
  • Aklo09Aklo09 Member Posts: 25
    Same here, stuck after killing last whisperer with overwatch
  • GovernatorGovernator Member Posts: 3,950
    I think Revenge trait might also play a role. I remember killing the first Whisperer that way and getting stuck. Going to try straight up killing without any traits kicking in to kill them. Wish me luck! :lol:
    JenngTHCross
  • JenngJenng Member Posts: 3,410
    Lol using 0 traits purposely is gonna be a real challenge @Governator !

    GovernatorTHCross
  • GovernatorGovernator Member Posts: 3,950
    Just completed the first map! Straight up killed the first guy with a double tap from Aaron. But second Whisperer ran at us and Overwatch got him. But map completed. The bug may be related to how you kill the first one. Hmmmmmmm...
    JenngTHCross
  • Camel56Camel56 Member Posts: 550
    I run 2 accounts, and out of the 12 missions played, it only happened one time. A guildmate also had to flee to end the mission. His glitch was using default survivors, mine happened during my first mission with my own survivors. Reported glitch to help desk, and their response was that they would compensate those affected with gold. We'll just have to wait and see.
    Governator
  • GovernatorGovernator Member Posts: 3,950
    This was no walk in the park to complete, but finished it by making sure I didn’t kill the first Whisperer on Overwatch, Revenge, or Retaliate. That seemed to be the trick.

    @Fluxxx. Can I get a “Bug Crusher” badge too? :lol:
    Jenng
Sign In or Register to comment.