Help from any tech person in here, please! Can't load forum on an old device...

Hello! Any help would be very much appreciated! I play the game on my phone and forum loads fine from google search bar. I have an old phone that I usually come to the forum on while I'm playing game on current phone. I use the Google search bar to come to forum and have done that for years. I noticed that it wouldn't pull up the forum Monday so thought maybe it had something to do with update. I could still access forum from current phone tho. So I rebooted old phone, I've cleared cache, but still it won't load right. Here's pics of what it looks like when I try to load it....any ideas about what's going on?


  • ZetteZette Member Posts: 416
    Oh cool! Thanks so much @ghost_pepper! I'll try that!
  • ZetteZette Member Posts: 416
    Yep! That worked! Chrome was the problem. Thank u so much!
  • ghost_pepperghost_pepper Member Posts: 736
    My phone is now permanently viewing the nml forum like the pictures shown from the op. I've tried 3 browsers. So it's not the browsers. My neighbors iphone showed it too, so it's not an android or apple thing.

    It's unusable by phone. Now I come visit with the computer for the first time and find the forum looking like this! 
  • GovernatorGovernator Member Posts: 4,409
    I can read it, but 01001001 00100000 01100001 01101101 00100000 01100110 01101100 01110101 01100101 01101110 01110100 00100000 01101001 01101110 00100000 01100010 01101001 01101110 01100001 01110010 01111001 00100000 01101100 01100001 01101110 01100111 01110101 01100001 01100111 01100101 00101110

  • 3vilrine3vilrine Member Posts: 259
    "Now I come visit with the computer for the first time and find the forum looking like this! "
    It doesn’t look like that normally. It is also bugged.

Sign In or Register to comment.