Maggie and Glenn's leadership traits aren't working!

DesertRangerDesertRanger Member Posts: 2
edited November 2017 in Bug Reports
For me Maggie and Glenn's leadership traits don't work anymore! I contacted support when I noticed Glenn's leadership trait isn't working! And the reply I got was that it was a visual glitch at the reward screen at the end of mission, and glenns extra earned supplies simply werent being displayed and that the extra supplies/ experience were being added on in the background..I am insulted by this reply as it is not true and that support seems to think its customers are unable to count. I can see during the mission nothing extra is being earned for either Maggie's or Glenn's leadership traits and I have added up the experience earned from the mission and reward crates, added it onto the total I had before the mission and can clearly see nothing has been added on in background for Maggie's trait, and can clearly see Maggies leadership trait is earning nothing extra and is not working, likewise for Glenn's leadership trait when he is in the leadership role! Is anyone else having this problem??

Comments

  • zbotzbot NML Legendary Moderator, OW Moderator Posts: 6,661
    @DesertRanger are you using Glenn and Maggie on the lead position? Their ability only works in the lead position.

    If you are using them in the lead position and it’s not working run a mission with different survivors then switch them back.

    Glenn’s leadership trait shows the supplies separately but Maggie’s doesn’t the xp earned with Maggie is already boosted.

    Hope this helps, if you have screenshots of the mission recap screen that would help in figuring things out and welcome to the forum.
  • zbotzbot NML Legendary Moderator, OW Moderator Posts: 6,661
    edited November 2017
    Screenshots for comparison.

    9 kills for Maggie vs 10 kills for Glenn

    6,102 xp vs. 4,774 xp
  • DesertRangerDesertRanger Member Posts: 2
    edited November 2017
    Yes I was using them in the lead position but the prob has been resolved now, I hope, thanks.
Sign In or Register to comment.