PSA: Having cinema issues on Android? Update Google Play Services.

This is a mandatory service, and I thought they were supposed to be automatically updated. But for some reason it did not on my phone.

You can get it directly from the play store here:
https://play.google.com/store/apps/details?id=com.google.android.gms

After updating it brought me up to version 9.2.56, and I haven't had a single ad fail since.

Looks like this one wasn't NG's fault. BAD GOOGLE!
shakhidIllbrainertheRealBender

Comments

  • masmith93masmith93 Member Posts: 3,522
    So what's the issue on the apple side?
    Proud member of the Empty Memorial Club.
    WHMGTYSNNBC - Retirement Guild Leader
    Coming soon to Finland to hug Teeceezy.
    This space intentionally left blank.
  • zosonzoson Member Posts: 2,216
    I don't have an issue on iOS to begin with. I'm on iOS 9.2.
  • masmith93masmith93 Member Posts: 3,522
    9.3.2. I've had an issue for a two weeks.
    Proud member of the Empty Memorial Club.
    WHMGTYSNNBC - Retirement Guild Leader
    Coming soon to Finland to hug Teeceezy.
    This space intentionally left blank.
  • zosonzoson Member Posts: 2,216
    I'm now 16/16 of the last 16 videos I've played from the cinema and from after missions.
    Definitely was my issue.
  • GladiGladi Member Posts: 616
    @zoson any Idea how to force this app to upgrade? I had 9.0.xxx version and problem with videos till now. To push it a bit, I uninstalled all updates for google services and all vids are working now as well :) But I believe, that updated app should be better.
  • zosonzoson Member Posts: 2,216
    @Gladi You have to match your device's firmware, cpu architecture, resolution, and DPI.
    You can figure out which apk you need and download that apk based on the guide here:
    http://www.apkmirror.com/apk/google-inc/google-play-services/google-play-services-9-2-56-release/

    Copy it to your SD Card and then you should just be able to open it directly on your phone to upgrade.

    So, for example, I'm on an N900 with Android 4.4.4 which has an arm architecture armeabi-v7a, resolution of 1080x1920 and a dpi of 480. So I would use the 9.2.56 (038-124593566) file.

    I think the most difficult thing to figure out is the arm architecture of your device. I figured this out by googling N900 and then each of the architectures, and eventually found some documentation that stated the N900 uses armeabi-v7a.

    Play services 9.0.83 was released at the end of May, I'm not sure the exact date, but that's the release I was on. So it looks like google updated me to that, then DIDN'T update me to 9.2.55 or 9.2.56 when that was released. 9.2.56 came out on June 13th, so it's possible that I would have gotten that eventually automatically. The timing is just too perfect for it to be coincidence that ads stopped working around that time as well, which made it look like the problem was because of the 1.9 release of NML even when it wasn't.
  • mangemysmangemys Member Posts: 2
    @zoson I updated to 9.2.56 but I still have the same problem.. any other options?
    @Gladi How did you uninstall all updates? It seems to be out-grayed for me.
Sign In or Register to comment.