Large Caliber trait: Just a Visual bug or ...?

124

Comments

  • @Shut_Up I didn't think someone would create a thread when there were so many other threads about the same thing.
    I came to the forum with my screenshots ready to start the same thread and instantly saw others had the same issue. Should merge all of them to the redundancy thread.
  • JayZJayZ Member Posts: 3,709
    @brentp17 thank you! worked like a charm for me
    Proud member of Mavericks OG, a top 3 global GW and challenge guild.
    Message me on the forums or on Line (ID: jayztwdnml) if you're interested in joining the Mavericks family of guilds.

    Youtube channel: https://www.youtube.com/channel/UCGSePrANMyf_S_YKJyfJodg
    Strategy compendium: https://forums.nextgames.com/walkingdead/discussion/41787/jayzs-nml-strategy-compendium
    Fester17
  • zeeblackzeeblack Member Posts: 1,200
    Some of the weapon or armor trait really does not work. e.g. the +health trait of armor does not work. Though, the dodge does work. Similarly, the arc of weapon trait work but the 10% damage does not work. NG needs to look into the issue and resolve it. Similar case is with some of the survivor traits

    Zee Black 

    Playing the game since 2015, Level 75 and 200K plus stars

    Part of SG Woot since 2016. We have played more than 300 challenges and earned  4 million plus stars

  • [Deleted User][Deleted User] Posts: 2,344
    This is horrible 2 of my assaults are literally stuck in what they are wearing until I upgrade them and I was using them in the challenge. :(
  • @DarkFae do an easy side mission until you can grab a jacket from a crate. Even a crappy jacket will work for the un-equip.
  • [Deleted User][Deleted User] Posts: 2,344
    [Deleted User]
  • The traits are still there unlocked, but they are simply not working in combat. Serious bug.
    @Teeceezy
  • @DarkFae at least you didn't post a new thread.
  • @R03 did you try to un-equip them re-equip?
  • @Amazayn I wish they would sticky this thread.
  • personlllpersonlll Member Posts: 79
    @Teeceezy

    I feel like large caliber doesn't work, or was nerfed.

    Wide spread also seems different.
  • eldazeldaz Member Posts: 18

    Today also my 3 long-range weapons improved lost their reach grid was very bad
  • TeliantesTeliantes Member Posts: 11
    I tried reequipping characters but I have 2 hunters that I know for sure went down 50 points in their damage last night because I know they were at 803 and are now at 753. On top of that, the dodge is out of hand...I just raided 3 people who I couldn't get a hit in no matter what...I have legendary equipment and even with a warrior who had double shots they were dodging a sword being swing at them? How do they do that? It isn't even just dodging bullets but I went after one character 12 times and no damage....am about to quit this stupid game after just investing about $500 in it. Thanks for ruining my favorite pastime....
  • Pain WalkerPain Walker Content Creator Posts: 2,624
    Unequip all weapons and armor, then re-equip them. It should fix the problem.

    Temporary fix before NG fixes It

    Probably making a video!

    My Youtube Channel: https://www.youtube.com/user/MultiPainproduction
  • Pain WalkerPain Walker Content Creator Posts: 2,624
    Unequip all weapons and armor, then re-equip them. It should fix the problem.

    Probably making a video!

    My Youtube Channel: https://www.youtube.com/user/MultiPainproduction
  • TeeceezyTeeceezy Staff Posts: 3,577
    Looking in to it, should have a solution soon. In the meantime, try unequipping and equipping the gear and it should go back to normal.
    EL34xyz
  • Conan1976Conan1976 Member Posts: 758
    un equipping not working me
    Looking for a guild? The Den is the place to be!
    We bring the fun back! Game Tips and Videos! Common interest non-game related chats too!
    Everyone is Welcome!

    Grimes Den & Dixons Den: competitive / different play styles
    Shivas Den: semi-competitive / relaxed Maggies Den: training and growth

    Email us to make our home your home: [email protected]
  • theRealBendertheRealBender Member Posts: 1,251
    edited June 2016
    Wow. Will try the re-equipping workaround

    Edit: so that worked but then i noticed how the damage numbers are not being calculated right. Equipping a lower damage item gave me MORE overall damage lol
    Back from 2016 :p
    ggbats
  • eldazeldaz Member Posts: 18
    the same thing happened to me, guns and vests does not work
  • eldazeldaz Member Posts: 18
    the same thing happened to me, guns and vests does not work
  • SpipmanSpipman Member Posts: 220
    Didn't work for me either guys...I hope they fix it asap.
  • DirtyDaveDirtyDave Member Posts: 1
    My problem is I don't have any backup equipment so I can't re-equip
  • SteelemanSteeleman Member Posts: 67
    Fixes bug
  • LightfeetLightfeet Member Posts: 1,062
    Re-equipping doesn't resolve the problems.
  • MystiqueMystique Content Creator ❤️ Posts: 1,454
    edited June 2016
    My Hunter which I leveled up to 19 yesterday now has 5 less damage than when she was level 18!?? Also my shooter has about 200 less damage! Not sure about the others!

    And yes I tried re-equipping my weapons!
    ⚔️ Leader/Elder TheHerdReborn/TheHerdReturned⚔️
    🌟IGN: Rene 🌟 Line ID: Mystique_01
    AndyMenshelFragzie
  • Neil_JNeil_J Member Posts: 1,873
    Apologies is this has already been covered, but my wide spread/bore on Assaults and hunters that I spent around 2mil xp on seems to have disappeared.
    Has this happened to anyone else?
    Is this a feature or a bug?

    Again, apologies if this has been covered but there are a hell of a lot of new posts since I last logged in.....
    “You never know how strong you are until being strong is your only option.” (Bob Marley)
  • theRealBendertheRealBender Member Posts: 1,251
    And they are all about what you just posted :smiley:
    Back from 2016 :p
    Shut_UpTeeceezy
  • Shut_UpShut_Up Member Posts: 2,295
    edited June 2016
    Look through the index for this section or the bug section. I think we'reup to 9 new threads on it
  • OldGothOldGoth Member Posts: 297
    A fix is now in place. It will take some time (typically an hour) to reach everyone (on your next log-in).
  • Rick_ZKRick_ZK Member Posts: 296
    Thanks @OldGoth
    IGN : Rick. Officer in the Cure Family. Number One in Sweden & currently 22 globally.
Sign In or Register to comment.